UX32A does not power on (Only powerlight and capslock light)

Discussion in 'Hardware' started by Adam N, Jan 2, 2016.

  1. Adam N

    Adam N New Member

    Likes Received:
    Trophy Points:
    UX32A will not turn although Power LED on button and the Power LED on the right side near the headphone jack and strangely also Capslock LED do come on and stay on. Fans cycle on and off. Display does not come on. For some freakish reason I was able to get it boot up once after multiple attempts but after shutting it down I have not been able again. Tried disconnecting and reconnecting the CMOS battery and of course the main battery. Made no difference. Removed the RAM and hard drive. Still no display. Oh and also attempted to connect to HDMI monitor and use F8 key to switch screens. Nothing.

    Can anyone confirm if this is indeed a motherboard issue or some sort of keyboard issue as I saw some references on some other website forums that people having similar problems with other Zenbooks were actually caused by a bad keyboard. And no, nothing was spilled in this keyboard.

    Oh and also Powercord LED is green when plugged in though the power jack does appear to have a short if you don't get the power cord in the right position but I see that as an unrelated issue but figured I'd mention it.

    Thanks in advance,
    Last edited: Jan 2, 2016

Share This Page